Accessing the ISO Deliverable

On UNIX

Utilities are available that can make a standard ISO file accessible as a block device, like an optical disk, which can then be mounted and accessed as a file system. See examples below.

Example: Solaris

# mkdir /mnt/iso

# lofiadm -a /tmp/rlty-V15.4.BN.10318.iso /dev/lofi/1

# mount -F hsfs -o ro /dev/lofi/1 /mnt/iso

# cd /mnt/iso

# ./setup

Example: Linux

# mkdir /mnt/disk

# mount -o loop disk1.iso /mnt/disk

# cd /mnt/disk

# ./setup

Example: AIX

#/usr/sbin/crfs -v jfs -g rootvg -a size=800 -m/cd1iso -Ano -pro -tno -a frag=4096 -a nbpi=4096 -a ag=8

# dd if=image.iso of=/dev/rlv00 bs=10M

# chfs -a vfs=cdrom cd1iso

# mount /cd1iso

# cd /cd1iso

# ./setup

When done unmount and remove the file system:

# rmfs /cd1iso